Hi,
I noticed that the IPv address used to perform the federation test is not right, it is the IP of the domain instead of the one of my matrix subdomain.
well-known delegation is set up correctly but maybe it is failing because of the redirect (https://ich-stuhle.de/.well-known/matrix/client → matrix subdomain) we configured.
This is my test result: Results: ich-stuhle.de
Thank you in advance for your help. The connectivity tester turned out really great over the time!
Yours
Pascal
Hi 
I took a closer look. My code currently does do ipv4 and ipv6 checks in parallel to identify when some part of the network is not correctly resolving things but the other half is.
It appears that the well known file on that domain can’t be reached at all over IPv6. It’s also (which I should make clearer) the server-server API wellknown thats the issue here rather than the client side one (as that runs client-side in the browser). On IPv4 I get the wellknown file but via IPv6 I am unable to reach the wellknown file on 2 independent networks. Port 443 on ipv6 for ich-stuhle.de seems to just hang and not return any response. It resolves fully and correctly on ipv4 only.
I did improve the error message too. However that fix is not yet deployed.
Oh and the port 8448 it tests happens because the wellknown times out and it then falls through to 8448 instead of correctly resolving things.
Same problem on my side. I don’t know why the site is not reachable, but I’ll check it. Thank you for the hint.